<!DOCTYPE html>
<!--[if lt IE 7]>      <html class="no-js lt-ie9 lt-ie8 lt-ie7" lang="en-US"> <![endif]-->
<!--[if IE 7]>         <html class="no-js lt-ie9 lt-ie8" lang="en-US"> <![endif]-->
<!--[if IE 8]>         <html class="no-js lt-ie9" lang="en-US"> <![endif]-->
<!--[if gt IE 8]><!--> <html class="no-js" lang="en-US"> <!--<![endif]-->
    <head>
	<meta charset="UTF-8" />
        <meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
	<title>Kay Granger and J.D. Granger &#8211; Tarrant Counties &#8211; &#8220;Joe and Hunter Biden&#8221; | Local News Only</title>
	<link rel="profile" href="http://gmpg.org/xfn/11">
	<link rel="pingback" href="https://www.localnewsonly.com/xmlrpc.php">

<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1">
<link rel="shortcut icon" href="" />
<link rel="apple-touch-icon" href="https://www.localnewsonly.com/wp-content/themes/goodnews5/apple-touch-icon-precomposed.png" />

<link rel="pingback" href="https://www.localnewsonly.com/xmlrpc.php" />
        <!--[if lt IE 9]>
	<script src="https://www.localnewsonly.com/wp-content/themes/goodnews5/framework/helpers/js/html5.js"></script>
	<script src="https://www.localnewsonly.com/wp-content/themes/goodnews5/framework/helpers/js/IE9.js"></script>
	<![endif]-->
	<script type='text/javascript'>function ctSetCookie(c_name, value, def_value){document.cookie = c_name + '=' + escape(value) + '; path=/';}ctSetCookie('ct_checkjs', '1371580943', '0');</script><link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Local News Only &raquo; Feed" href="https://www.localnewsonly.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Local News Only &raquo; Comments Feed" href="https://www.localnewsonly.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Local News Only &raquo; Kay Granger and J.D. Granger &#8211; Tarrant Counties &#8211; &#8220;Joe and Hunter Biden&#8221; Comments Feed" href="https://www.localnewsonly.com/2020/01/kay-granger-and-j-d-granger-tarrant-counties-joe-and-hunter-biden/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.localnewsonly.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.2.2"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='layerslider-css'  href='https://www.localnewsonly.com/wp-content/plugins/LayerSlider/static/layerslider/css/layerslider.css?ver=6.7.6' type='text/css' media='all' />
<link rel='stylesheet' id='ls-google-fonts-css'  href='https://fonts.googleapis.com/css?family=Lato:100,300,regular,700,900%7COpen+Sans:300%7CIndie+Flower:regular%7COswald:300,regular,700&#038;subset=latin%2Clatin-ext' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://www.localnewsonly.com/wp-includes/css/dist/block-library/style.min.css?ver=5.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='https://www.localnewsonly.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.1.3' type='text/css' media='all' />
<link rel='stylesheet' id='plugins-css'  href='https://www.localnewsonly.com/wp-content/themes/goodnews5/css/plugins.css?ver=5.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='main-css'  href='https://www.localnewsonly.com/wp-content/themes/goodnews5/css/main.css?ver=5.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='responsive-css'  href='https://www.localnewsonly.com/wp-content/themes/goodnews5/css/media.css?ver=5.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='style-css'  href='https://www.localnewsonly.com/wp-content/themes/goodnews5/style.css?ver=5.2.2' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var LS_Meta = {"v":"6.7.6"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.localnewsonly.com/wp-content/plugins/LayerSlider/static/layerslider/js/greensock.js?ver=1.19.0'></script>
<script type='text/javascript' src='https://www.localnewsonly.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://www.localnewsonly.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://www.localnewsonly.com/wp-content/plugins/LayerSlider/static/layerslider/js/layerslider.kreaturamedia.jquery.js?ver=6.7.6'></script>
<script type='text/javascript' src='https://www.localnewsonly.com/wp-content/plugins/LayerSlider/static/layerslider/js/layerslider.transitions.js?ver=6.7.6'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ctPublic = {"_ajax_nonce":"38f258d157","_ajax_url":"https:\/\/www.localnewsonly.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.localnewsonly.com/wp-content/plugins/cleantalk-spam-protect/js/apbct-public.min.js?ver=5.121'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ctNocache = {"ajaxurl":"https:\/\/www.localnewsonly.com\/wp-admin\/admin-ajax.php","info_flag":"","set_cookies_flag":"","blog_home":"https:\/\/www.localnewsonly.com\/"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.localnewsonly.com/wp-content/plugins/cleantalk-spam-protect/js/cleantalk_nocache.min.js?ver=5.121'></script>
<meta name="generator" content="Powered by LayerSlider 6.7.6 - Multi-Purpose, Responsive, Parallax, Mobile-Friendly Slider Plugin for WordPress." />
<!-- LayerSlider updates and docs at: https://layerslider.kreaturamedia.com -->
<link rel='https://api.w.org/' href='https://www.localnewsonly.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.localnewsonly.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.localnewsonly.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='McLaren Dallas Gives 11-Year-Old Children’s Health SM Patient the Ride of His Life in a McLaren 720S' href='https://www.localnewsonly.com/2020/01/mclaren-dallas-gives-11-year-old-childrens-health-sm-patient-the-ride-of-his-life-in-a-mclaren-720s/' />
<meta name="generator" content="WordPress 5.2.2" />
<link rel="canonical" href="https://www.localnewsonly.com/2020/01/kay-granger-and-j-d-granger-tarrant-counties-joe-and-hunter-biden/" />
<link rel='shortlink' href='https://www.localnewsonly.com/?p=28083' />
<link rel="alternate" type="application/json+oembed" href="https://www.localnewsonly.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.localnewsonly.com%2F2020%2F01%2Fkay-granger-and-j-d-granger-tarrant-counties-joe-and-hunter-biden%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.localnewsonly.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.localnewsonly.com%2F2020%2F01%2Fkay-granger-and-j-d-granger-tarrant-counties-joe-and-hunter-biden%2F&#038;format=xml" />
<meta name="generator" content="Powered by WPBakery Page Builder - drag and drop page builder for WordPress."/>
<!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="https://www.localnewsonly.com/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]--><style type="text/css" title="dynamic-css" class="options-output">.mom_main_font,.topbar,#navigation .main-menu,.breaking-news,.breaking-news .bn-title,.feature-slider li .slide-caption h2,.news-box .nb-header .nb-title,a.show-more,.widget .widget-title,.widget .mom-socials-counter ul li,.main_tabs .tabs a,.mom-login-widget,.mom-login-widget input,.mom-newsletter h4,.mom-newsletter input,.mpsw-slider .slide-caption,.tagcloud a,button,input,select,textarea,.weather-widget,.weather-widget h3,.nb-inner-wrap .search-results-title,.show_all_results,.mom-social-share .ss-icon span.count,.mom-timeline,.mom-reveiw-system .review-header h2,.mom-reveiw-system .review-summary h3,.mom-reveiw-system .user-rate h3,.mom-reveiw-system .review-summary .review-score,.mom-reveiw-system .mom-bar,.mom-reveiw-system .review-footer,.mom-reveiw-system .stars-cr .cr,.mom-reveiw-system .review-circles .review-circle,.p-single .post-tags,.np-posts ul li .details .link,h2.single-title,.page-title,label,.portfolio-filter li,.pagination .main-title h1,.main-title h2,.main-title h3,.main-title h4,.main-title h5,.main-title h6,.mom-e3lan-empty,.user-star-rate .yr,.comment-wrap .commentnumber,.copyrights-area,.news-box .nb-footer a,#bbpress-forums li.bbp-header,.bbp-forum-title,div.bbp-template-notice,div.indicator-hint,#bbpress-forums fieldset.bbp-form legend,.bbp-s-title,#bbpress-forums .bbp-admin-links a,#bbpress-forums #bbp-user-wrapper h2.entry-title,.mom_breadcrumb,.single-author-box .articles-count,.not-found-wrap,.not-found-wrap h1,.gallery-post-slider.feature-slider li .slide-caption.fs-caption-alt p,.chat-author,.accordion .acc_title,.acch_numbers,.logo span,.device-menu-holder,#navigation .device-menu,.widget li .cat_num, .wp-caption-text, .mom_quote, div.progress_bar span, .widget_display_stats dl, .feature-slider .fs-nav.numbers a{font-family:Arial, Helvetica, sans-serif;}.button, .scrolling-box .sb-item h3, .widget ul li, .older-articles ul li, .copyrights-text, #comments .single-comment .comment-content .comment-reply-link, #comments .single-comment .comment-content .comment-edit-link, #navigation .main-menu > li .cats-mega-wrap .subcat li .subcat-title, .widget ul.twiter-list, #bbpress-forums ul.bbp-replies .bbp-reply-content .bbp-author-name, h1, h2, h3, h4, h5, h6{font-family:'Arial Black', Gadget, sans-serif;}body{font-family:Arial, Helvetica, sans-serif;text-align:left;line-height:18px;font-weight:400;font-style:normal;color:#0c0c0c;font-size:16px;}</style><style type="text/css">
    
.header > .inner, .header .logo {
line-height: 165px;
height: 165px;
}
/* Category background */
                                            </style>
<noscript><style type="text/css"> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript>    </head>
    <body class="post-template-default single single-post postid-28083 single-format-standard both-sidebars-all both-sidebars singular both_sidebars_same_width navigation_highlight_ancestor ticker_has_live_time time_in_twelve_format one-side-wide both-sidebars both-sides-true wpb-js-composer js-comp-ver-5.6 vc_responsive" itemscope="itemscope" itemtype="http://schema.org/WebPage">
    
        <!--[if lt IE 7]>
            <p class="browsehappy">You are using an <strong>outdated</strong> browser. Please <a href="http://browsehappy.com/">upgrade your browser</a> to improve your experience.</p>
        <![endif]-->
        <div class="boxed-wrap clearfix">
	    <div id="header-wrapper">
                         <div class="topbar">
  <div class="inner">
            <div class="top-left-content">
            		    <ul class="mom-social-icons">
                    <li class="twitter"><a target="_blank" class="vector_icon" href="#"><i class="fa-icon-twitter"></i></a></li>
        
                <li class="facebook"><a target="_blank" class="vector_icon" href="#"><i class="fa-icon-facebook "></i></a></li>        
        
                   <li class="gplus"><a target="_blank" class="vector_icon" href="#" ><i class="fa-icon-google-plus"></i></a></li>     
        
                        <li class="linkedin"><a target="_blank" class="vector_icon" href="#"><i class="fa-icon-linkedin"></i></a></li>
        
        
        
        
        

        

        
                                     <li class="rss"><a target="_blank" class="vector_icon" href="https://www.localnewsonly.com/feed/"><i class="fa-icon-rss"></i></a></li>
        	
	    </ul>		       </div> <!--tb left-->
        <div class="top-right-content">
            		    <ul class="mom-social-icons">
                    <li class="twitter"><a target="_blank" class="vector_icon" href="#"><i class="fa-icon-twitter"></i></a></li>
        
                <li class="facebook"><a target="_blank" class="vector_icon" href="#"><i class="fa-icon-facebook "></i></a></li>        
        
                   <li class="gplus"><a target="_blank" class="vector_icon" href="#" ><i class="fa-icon-google-plus"></i></a></li>     
        
                        <li class="linkedin"><a target="_blank" class="vector_icon" href="#"><i class="fa-icon-linkedin"></i></a></li>
        
        
        
        
        

        

        
                                     <li class="rss"><a target="_blank" class="vector_icon" href="https://www.localnewsonly.com/feed/"><i class="fa-icon-rss"></i></a></li>
        	
	    </ul>
                    </div> <!--tb right-->
</div>
 </div> <!--topbar-->
             <header class="header " itemscope="itemscope" itemtype="http://schema.org/WPHeader" role="banner">
                <div class="inner">
						                    <div class="logo">
					                    <a href="https://www.localnewsonly.com">
		                                                    <img src="https://www.localnewsonly.com/wp-content/uploads/2015/04/LNOwebretina-01.png" alt="Local News Only" width="300" height="160" />
                                                                    <img class="mom_retina_logo" src="https://www.localnewsonly.com/wp-content/uploads/2015/04/LNOwebretina-01.png" width="300" height="160" alt="Local News Only" />
                        		                    </a>

					
                    </div>
                                        <div class="header-right">
                                  		<div class="mom-e3lanat-wrap  ">
	<div class="mom-e3lanat " style="">
		<div class="mom-e3lanat-inner">
		
		</div>
	</div>	<!--Mom ads-->
	</div>
                    </div> <!--header right-->
                    
                <div class="clear"></div>
                </div>
            </header>
	    	    </div> <!--header wrap-->
                                    <nav id="navigation" itemtype="http://schema.org/SiteNavigationElement" itemscope="itemscope" role="navigation" class="dd-effect-slide ">
                <div class="navigation-inner">
                <div class="inner">
                                                                <ul id="menu-main-menu" class="main-menu mom_visibility_desktop"><li id="menu-item-4649" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home mom_default_menu_item menu-item-iconsOnly menu-item-depth-0"><a href="https://www.localnewsonly.com/"><i class="icon_only momizat-icon-home"></i><span class="icon_only_label">Home</span></a></li>
<li id="menu-item-15647" class="menu-item menu-item-type-taxonomy menu-item-object-category mom_default_menu_item menu-item-depth-0"><a href="https://www.localnewsonly.com/category/breaking-news/">Breaking News</a></li>
<li id="menu-item-15649" class="menu-item menu-item-type-taxonomy menu-item-object-category mom_default_menu_item menu-item-depth-0"><a href="https://www.localnewsonly.com/category/news-release/">News Releases</a></li>
<li id="menu-item-4605" class="menu-item menu-item-type-taxonomy menu-item-object-category mom_default_menu_item menu-item-depth-0"><a href="https://www.localnewsonly.com/category/politics/">Politics</a></li>
<li id="menu-item-4606" class="menu-item menu-item-type-taxonomy menu-item-object-category mom_default_menu_item menu-item-depth-0"><a href="https://www.localnewsonly.com/category/business/">Local Business</a></li>
<li id="menu-item-4874" class="menu-item menu-item-type-taxonomy menu-item-object-category mom_default_menu_item menu-item-depth-0"><a href="https://www.localnewsonly.com/category/city-government/">City Government</a></li>
<li id="menu-item-4718" class="menu-item menu-item-type-taxonomy menu-item-object-category mom_default_menu_item menu-item-depth-0"><a href="https://www.localnewsonly.com/category/crime/">Crime</a></li>
<li id="menu-item-4607" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-parent-item mom_default_menu_item menu-item-depth-0"><a href="https://www.localnewsonly.com/category/editorials/">Editorials</a>
<ul class="sub-menu ">
	<li id="menu-item-4608" class="menu-item menu-item-type-taxonomy menu-item-object-category mom_default_menu_item active menu-item-depth-1"><a href="https://www.localnewsonly.com/category/letters-to-the-editor/">Letters to the Editor</a></li>
</ul>
<i class='responsive-caret'></i>
</li>
<li id="menu-item-4717" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-parent-item mom_default_menu_item menu-item-depth-0"><a href="https://www.localnewsonly.com/category/lifestyleentertainment/">Lifestyle &#038; Entertainment</a>
<ul class="sub-menu ">
	<li id="menu-item-4720" class="menu-item menu-item-type-taxonomy menu-item-object-category mom_default_menu_item active menu-item-depth-1"><a href="https://www.localnewsonly.com/category/school-news/">School News</a></li>
</ul>
<i class='responsive-caret'></i>
</li>
<li id="menu-item-4719" class="menu-item menu-item-type-taxonomy menu-item-object-category mom_default_menu_item menu-item-depth-0"><a href="https://www.localnewsonly.com/category/little-known-facts/">Little Known Facts</a></li>
<li id="menu-item-4826" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-parent-item mom_default_menu_item menu-item-depth-0"><a href="https://www.localnewsonly.com/archive/">Archive</a>
<ul class="sub-menu ">
	<li id="menu-item-4950" class="menu-item menu-item-type-post_type menu-item-object-page mom_default_menu_item active menu-item-depth-1"><a href="https://www.localnewsonly.com/archive/">Current Archive</a></li>
	<li id="menu-item-4949" class="menu-item menu-item-type-custom menu-item-object-custom mom_default_menu_item menu-item-depth-1"><a href="http://archive.localnewsonly.com">Archives Before May 2015</a></li>
</ul>
<i class='responsive-caret'></i>
</li>
</ul>                                                                <div class="device-menu-wrap mom_visibility_device">
                        <div id="menu-holder" class="device-menu-holder">
                            <i class="fa-icon-align-justify mh-icon"></i> <span class="the_menu_holder_area"><i class="dmh-icon"></i>Menu</span><i class="mh-caret"></i>
                        </div>
                        <ul id="menu-main-menu-1" class="device-menu mom_visibility_device"><li id="menu-item-4649" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home mom_default_menu_item menu-item-iconsOnly menu-item-depth-0"><a href="https://www.localnewsonly.com/"><i class="icon_only momizat-icon-home"></i><span class="icon_only_label">Home</span></a></li>
<li id="menu-item-15647" class="menu-item menu-item-type-taxonomy menu-item-object-category mom_default_menu_item menu-item-depth-0"><a href="https://www.localnewsonly.com/category/breaking-news/">Breaking News</a></li>
<li id="menu-item-15649" class="menu-item menu-item-type-taxonomy menu-item-object-category mom_default_menu_item menu-item-depth-0"><a href="https://www.localnewsonly.com/category/news-release/">News Releases</a></li>
<li id="menu-item-4605" class="menu-item menu-item-type-taxonomy menu-item-object-category mom_default_menu_item menu-item-depth-0"><a href="https://www.localnewsonly.com/category/politics/">Politics</a></li>
<li id="menu-item-4606" class="menu-item menu-item-type-taxonomy menu-item-object-category mom_default_menu_item menu-item-depth-0"><a href="https://www.localnewsonly.com/category/business/">Local Business</a></li>
<li id="menu-item-4874" class="menu-item menu-item-type-taxonomy menu-item-object-category mom_default_menu_item menu-item-depth-0"><a href="https://www.localnewsonly.com/category/city-government/">City Government</a></li>
<li id="menu-item-4718" class="menu-item menu-item-type-taxonomy menu-item-object-category mom_default_menu_item menu-item-depth-0"><a href="https://www.localnewsonly.com/category/crime/">Crime</a></li>
<li id="menu-item-4607" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-parent-item mom_default_menu_item menu-item-depth-0"><a href="https://www.localnewsonly.com/category/editorials/">Editorials</a>
<ul class="sub-menu ">
	<li id="menu-item-4608" class="menu-item menu-item-type-taxonomy menu-item-object-category mom_default_menu_item active menu-item-depth-1"><a href="https://www.localnewsonly.com/category/letters-to-the-editor/">Letters to the Editor</a></li>
</ul>
<i class='responsive-caret'></i>
</li>
<li id="menu-item-4717" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-parent-item mom_default_menu_item menu-item-depth-0"><a href="https://www.localnewsonly.com/category/lifestyleentertainment/">Lifestyle &#038; Entertainment</a>
<ul class="sub-menu ">
	<li id="menu-item-4720" class="menu-item menu-item-type-taxonomy menu-item-object-category mom_default_menu_item active menu-item-depth-1"><a href="https://www.localnewsonly.com/category/school-news/">School News</a></li>
</ul>
<i class='responsive-caret'></i>
</li>
<li id="menu-item-4719" class="menu-item menu-item-type-taxonomy menu-item-object-category mom_default_menu_item menu-item-depth-0"><a href="https://www.localnewsonly.com/category/little-known-facts/">Little Known Facts</a></li>
<li id="menu-item-4826" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-parent-item mom_default_menu_item menu-item-depth-0"><a href="https://www.localnewsonly.com/archive/">Archive</a>
<ul class="sub-menu ">
	<li id="menu-item-4950" class="menu-item menu-item-type-post_type menu-item-object-page mom_default_menu_item active menu-item-depth-1"><a href="https://www.localnewsonly.com/archive/">Current Archive</a></li>
	<li id="menu-item-4949" class="menu-item menu-item-type-custom menu-item-object-custom mom_default_menu_item menu-item-depth-1"><a href="http://archive.localnewsonly.com">Archives Before May 2015</a></li>
</ul>
<i class='responsive-caret'></i>
</li>
</ul>                        </div>
                                            		    <div class="nav-buttons">
                                        		                        <span class="nav-button nav-search">
                        <i class="fa-icon-search"></i>
                    </span>
                    <div class="nb-inner-wrap search-wrap border-box">
                        <div class="nb-inner sw-inner">
                        <div class="search-form mom-search-form">
                            <form method="get" action="https://www.localnewsonly.com">
                                <input class="sf" type="text" placeholder="Search ..." autocomplete="off" name="s">
                                <button class="button" type="submit"><i class="fa-icon-search"></i></button>
                            </form>
                            <span class="sf-loading"><img src="https://www.localnewsonly.com/wp-content/themes/goodnews5/images/ajax-search-nav.gif" alt="loading..." width="16" height="16"></span>
                        </div>
                    <div class="ajax_search_results">
                    </div> <!--ajax search results-->
                    </div> <!--sw inner-->
                    </div> <!--search wrap-->
                    
        		    </div> <!--nav-buttons-->

                </div>
                </div> <!--nav inner-->
            </nav> <!--Navigation-->
            	    <div class="boxed-content-wrapper clearfix">
                        <div class="nav-shaddow"></div>
                         <div style="margin-top:-17px; margin-bottom:20px;"></div>
            
            <div class="inner">
                        
        <div class="breaking-news">
    <div class="the_ticker" >
    <div class="bn-title"><span>BREAKING NEWS</span></div>
    <div class="news-ticker " data-timeout="5000">
        <ul>
            <li><i class="fa-icon-double-angle-right"></i><a href="https://www.localnewsonly.com/2020/01/kay-granger-and-j-d-granger-tarrant-counties-joe-and-hunter-biden/">Kay Granger and J.D. Granger &#8211; Tarrant Counties &#8211; &#8220;Joe and Hunter Biden&#8221;</a></li>
            <li><i class="fa-icon-double-angle-right"></i><a href="https://www.localnewsonly.com/2020/01/mclaren-dallas-gives-11-year-old-childrens-health-sm-patient-the-ride-of-his-life-in-a-mclaren-720s/">McLaren Dallas Gives 11-Year-Old Children’s Health SM Patient the Ride of His Life in a McLaren 720S</a></li>
            <li><i class="fa-icon-double-angle-right"></i><a href="https://www.localnewsonly.com/2020/01/recent-arrests-and-book-ins-at-grapevine-city-jail-2/">Recent arrests and book-ins at Grapevine City Jail</a></li>
            <li><i class="fa-icon-double-angle-right"></i><a href="https://www.localnewsonly.com/2020/01/recent-arrests-in-southlake-4/">Recent Arrests in Southlake</a></li>
            <li><i class="fa-icon-double-angle-right"></i><a href="https://www.localnewsonly.com/2020/01/tragedy-in-southlake-takes-students-life/">Tragedy in Southlake takes student&#8217;s life</a></li>
        </ul>
    </div> <!--news ticker-->
    </div>
        <span class="current_time"><span></span> </span>
        </div> <!--breaking news-->
            </div>
    <div class="inner">
        
                            <div class="main_container">
           <div class="main-col">
                                <div class="category-title">
                                        </div>
                                        <div class="base-box blog-post p-single bp-horizontal-share post-28083 post type-post status-publish format-standard category-uncategorized"itemscope itemtype="http://schema.org/Article">
<div itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
    <meta itemprop="url" content="http://1.bp.blogspot.com/-dmGu5P61cZE/VSxoxOpcDBI/AAAAAAAAbmg/wPUh1uCcogs/s1600/Grangers.jpg">
    <meta itemprop="width" content="300">
    <meta itemprop="height" content="300">
  </div>
  <meta itemscope itemprop="mainEntityOfPage"  itemType="https://schema.org/WebPage" itemid="https://www.localnewsonly.com/2020/01/kay-granger-and-j-d-granger-tarrant-counties-joe-and-hunter-biden/"/>

  <div itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
    <div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
      <meta itemprop="url" content="https://www.localnewsonly.com/wp-content/uploads/2015/04/LNOwebretina-01.png">
      <meta itemprop="width" content="300">
      <meta itemprop="height" content="160">
    </div>
        <meta itemprop="name" content="Local News Only">
  </div>
  <meta itemprop="datePublished" content="2020-01-14T18:02:56-06:00"/>
  <meta itemprop="dateModified" content="2020-01-14T18:11:33-06:00"/>


                                   														<div class="feature-img">
								<img src="http://1.bp.blogspot.com/-dmGu5P61cZE/VSxoxOpcDBI/AAAAAAAAbmg/wPUh1uCcogs/s1600/Grangers.jpg" alt="Kay Granger and J.D. Granger - Tarrant Counties - "Joe and Hunter Biden"">
							</div>
							                                   <h1 class="post-tile entry-title" itemprop="headline">Kay Granger and J.D. Granger &#8211; Tarrant Counties &#8211; &#8220;Joe and Hunter Biden&#8221;</h1>
<div class="mom-post-meta single-post-meta"><span class="author vcard" itemprop="author" itemscope itemtype="https://schema.org/Person">Posted By: <span class="fn" itemprop="name"><a href="https://www.localnewsonly.com/author/nelson/">Editor - Nelson Thibodeaux</a></span></span><span>on: <time datetime="2020-01-14T18:02:56-06:00" class="updated">January 14, 2020</time></span><span>In: <a href="https://www.localnewsonly.com/category/uncategorized/" title="View all posts in Uncategorized">Uncategorized</a></span><span><a href="https://www.localnewsonly.com/2020/01/kay-granger-and-j-d-granger-tarrant-counties-joe-and-hunter-biden/#respond">No Comments</a></span><div class="post-tools"><a href="javascript:window.print()" rel="nofollow" class="print"><i class="fa-icon-print"> </i>Print</a><a href="mailto:?subject=Kay Granger and J.D. Granger &#8211; Tarrant Counties &#8211; &#8220;Joe and Hunter Biden&#8221;&body=Kay Granger and J.D. Granger &#8211; Tarrant Counties &#8211; &#8220;Joe and Hunter Biden&#8221; https://www.localnewsonly.com/2020/01/kay-granger-and-j-d-granger-tarrant-counties-joe-and-hunter-biden/" rel="nofollow" class="email"><i class="fa-icon-envelope"> </i>Email</a></div></div><div class="entry-content">
            <div class="fauxcolumn-outer fauxcolumn-left-outer">
<div class="fauxborder-left">
<div class="fauxborder-right"><strong><strong><span style="font-size: 14pt;">January 14, 2020, Colleyville, Texas</span></strong></strong></div>
</div>
<div>
<p>Editorial by LNO Editor Nelson Thibodeaux.</p>
</div>
</div>
<div><strong><span style="font-size: 14pt;">Texas has it&#8217;s own Joe &amp; Hunter Biden hook up with Kay &amp; J.D. Granger</span></strong></div>
<div class="fauxcolumn-outer fauxcolumn-left-outer">
<div class="fauxborder-left">
<div></div>
<div class="fauxborder-right"><strong><strong><span style="font-size: 14pt;">The Hunter Biden story seemingly  repeats itself with a Republican Congresswoman representing a large part of  DFW area.  It appears the sudden rise of former Councilman Chris Putnam, may be coming JUST at the RIGHT Moment!  That is JD has just been fired and leaves a legacy of hundreds of millions dollars wasted through his leadership, sans any background in the water or development business&#8230;..sound familiar?</span></strong></strong></div>
</div>
</div>
<div><strong><span style="font-size: 14pt;">While the saga of Joe Biden&#8217;s quid quo pro is one of the worse kept secrets in Washington Circles..Tarrant County has Congresswoman Kay Granger&#8217;s saga of very similar circustances.</span></strong></div>
<div class="fauxcolumn-outer fauxcolumn-left-outer">
<div class="fauxborder-left">
<div></div>
<div class="fauxborder-right">
<p><strong><strong><span style="font-size: 14pt;">Below the announcement that  &#8220;Hunter&#8221; J.D. Granger is out of the executive director&#8217;s chair of the Trinity River Vision Authority</span></strong></strong></p>
<p>NBC News: <strong><span style="color: rgba(0, 0, 0, 0.6); font-family: Roboto; font-size: 0.875rem; font-style: inherit; font-variant-ligatures: inherit; font-variant-caps: inherit;">The Trinity River Vision Authority announced plans to hire a new program coordinator which means the removal of executive director J.D. Granger who had headed up the Panther Island project since its beginning.</span></strong></p>
<p>&nbsp;</p>
</div>
<div class="fauxborder-right">
<div class="video-flyout" data-component="videoFlyout">
<div class="video-flyout__trigger"><strong><span style="font-size: 14pt;">Major management changes at the embattled Trinity River Vision Authority included the removal of its executive director, J.D. Granger, who had headed up the <a href="https://www.nbcdfw.com/investigations/Panther-Island-Problems-502598652.html" target="_blank" rel="noopener noreferrer">“Panther Island” project</a> since its beginning more than a dozen years ago.</span></strong></div>
</div>
<div class="article-content rich-text">
<p><strong><span style="font-size: 14pt;">Granger, the son of a powerful congresswoman who started the project, will instead work directly for Jim Oliver, head of the Tarrant Regional Water District.</span></strong></p>
<p><strong><span style="font-size: 14pt;">Oliver told NBC 5 Investigates that Granger will focus on flood control projects, while the economic development part of Panther Island &#8211; once a major interest for Granger &#8211; will be taken over by the city of Fort Worth.</span></strong></p>
</div>
</div>
</div>
</div>
<div class="columns-inner">
<div class="column-center-outer">
<div class="column-center-inner">
<div id="main" class="main section">
<div id="Blog1" class="widget Blog" data-version="1">
<div class="blog-posts hfeed">
<div class="date-outer">
<div class="date-posts">
<div class="post-outer">
<div class="post hentry">
<p><a href="http://1.bp.blogspot.com/-dmGu5P61cZE/VSxoxOpcDBI/AAAAAAAAbmg/wPUh1uCcogs/s1600/Grangers.jpg"><img class="alignnone wp-image-28084" src="https://www.localnewsonly.com/wp-content/uploads/2020/01/Bidens.jpg" alt="" width="363" height="331" srcset="https://www.localnewsonly.com/wp-content/uploads/2020/01/Bidens.jpg 634w, https://www.localnewsonly.com/wp-content/uploads/2020/01/Bidens-300x274.jpg 300w" sizes="(max-width: 363px) 100vw, 363px" /></a><a href="http://1.bp.blogspot.com/-dmGu5P61cZE/VSxoxOpcDBI/AAAAAAAAbmg/wPUh1uCcogs/s1600/Grangers.jpg"><img src="http://1.bp.blogspot.com/-dmGu5P61cZE/VSxoxOpcDBI/AAAAAAAAbmg/wPUh1uCcogs/s1600/Grangers.jpg" width="400" height="330" border="0" /></a></p>
<h3>On the left Joe and Hunter Biden         Allegedly of the right  Kay and J.D. Granger</h3>
<p><strong>Now comes former Colleyville Mayor Pro Tem in his first congressional race against the, here to fore, Queen of Tarrant County.  Putnam a committed conservative has launched a challenge, few thought possible,  to take on Kay Granger for her long term seat in the US Congress.<br />
<img class="alignnone size-large wp-image-28087" src="https://www.localnewsonly.com/wp-content/uploads/2020/01/Putnam-crowd-1024x368.jpg" alt="" width="1024" height="368" srcset="https://www.localnewsonly.com/wp-content/uploads/2020/01/Putnam-crowd-1024x368.jpg 1024w, https://www.localnewsonly.com/wp-content/uploads/2020/01/Putnam-crowd-300x108.jpg 300w, https://www.localnewsonly.com/wp-content/uploads/2020/01/Putnam-crowd-768x276.jpg 768w" sizes="(max-width: 1024px) 100vw, 1024px" /><br />
</strong>Putnam Speaks to a large gathering at the North Richland Hills Center on Monday night, even the national Championship didn&#8217;t keep these folks from coming out to hear more from Putnam.<br />
Tommy Snyder welcome Putnam to the stage with a great new rendition of don&#8217;t mess with Texas (Putnam). It would appear that Congressman&#8217;s previous comment that she would finish teh Panther Island project, then, &#8220;I&#8217;m out of here.&#8221;  will still have to muster past the voters of the<br />
<img class="alignnone wp-image-28088" src="https://www.localnewsonly.com/wp-content/uploads/2020/01/Synder-Putnam-song-1024x902.jpg" alt="" width="764" height="673" srcset="https://www.localnewsonly.com/wp-content/uploads/2020/01/Synder-Putnam-song-1024x902.jpg 1024w, https://www.localnewsonly.com/wp-content/uploads/2020/01/Synder-Putnam-song-300x264.jpg 300w, https://www.localnewsonly.com/wp-content/uploads/2020/01/Synder-Putnam-song-768x676.jpg 768w" sizes="(max-width: 764px) 100vw, 764px" /></p>
<h2 class="date-header"><strong><em>Published on Thursday, April 16, 2015</em></strong></h2>
<h3 class="post-title entry-title"><span style="font-size: 16px;">The Incredible Alternative Universe Of J.D. Granger &amp; America&#8217;s Biggest Boondoggle</span></h3>
<div id="post-body-9221332036705607297" class="post-body entry-content">
<div class="post-header" style="font-size: 16px;">
<div class="post-header-line-1">
<h3 class="post-title entry-title"><img class="alignnone size-full wp-image-28092" src="https://www.localnewsonly.com/wp-content/uploads/2020/01/durangologo.jpg" alt="" width="640" height="168" srcset="https://www.localnewsonly.com/wp-content/uploads/2020/01/durangologo.jpg 640w, https://www.localnewsonly.com/wp-content/uploads/2020/01/durangologo-300x79.jpg 300w" sizes="(max-width: 640px) 100vw, 640px" /></h3>
</div>
</div>
<div id="post-body-9221332036705607297" class="post-body entry-content" style="font-size: 16px;">
<div class="separator"><a href="http://1.bp.blogspot.com/-dmGu5P61cZE/VSxoxOpcDBI/AAAAAAAAbmg/wPUh1uCcogs/s1600/Grangers.jpg"><img src="http://1.bp.blogspot.com/-dmGu5P61cZE/VSxoxOpcDBI/AAAAAAAAbmg/wPUh1uCcogs/s1600/Grangers.jpg" width="400" height="330" border="0" /></a></div>
<p>Why is it when I see a photo of these two the <i>Manchurian Candidate</i> comes to mind?</p>
<p>The young lady you see here is Fort Worth&#8217;s Congresswoman, also known as the Queen of Nespot, Kay Granger, standing next to the Queen&#8217;s heir, J.D.</p>
<p>J.D. is the executive director of a pseudo public works project currently known as Panther Island, also currently known as The Boondoggle, recently recognized as America&#8217;s Biggest Boondoggle.</p>
<p>The Boondoggle being America&#8217;s Biggest Boondoggle marks the first time Fort Worth has had the biggest of anything in America. I doubt this is making city&#8217;s far and wide <b><a href="http://www.durangotexas.com/eyesontexas/fortworth/greenwithenvy.htm" target="_blank" rel="noopener noreferrer">Green with Envy</a></b>.</p>
<p>Over the years The Boondoggle has gone by various names. Trinity Uptown. Central City. Trinity River Vision. Panther Island. The Boondoggle.</p>
<p>I have heard various opinions as to when The Boondoggle began. I think some date the start of The Boondoggle to the start of initiating a name change. For instance, one might say The Boondoggle as Panther Island is two years into the project. While The Boondoggle as Trinity River Vision is nine years into the project. The Boondoggle as Trinity Uptown is 13 years into the project. Well, you get the idea.</p>
<p>Now, I have long said that my memory tells me The Boondoggle began way back in 1999. I remember soon upon my arrival in Texas learning of a Dallas Trinity River Vision for which Dallas voters had voted. Soon thereafter I recollect reading of a proposed similar Fort Worth vision. I remember thinking it odd, what with no mention made of a planned public vote. And also wondering if there was some sort of history of Fort Worth copying Dallas, what with the two visions seeming so similar, including both having three signature bridges.</p>
<p>Ironically, all these years later, Dallas has actually built one of its signature bridges, and a cool signature bridge it is, while Fort Worth long ago dropped the signature bridges and is now building three little bridges over dry land, with a four year construction schedule, far longer than it took Dallas to build its actual signature bridge over actual water.</p>
<p>I have had people tell me I am wrong when I say the Fort Worth Boondoggle has been boondoggling along since late in the last century. Some will date the start of The Boondoggle to 2002 or 2003. Some as late as 2006, that being the year Kay Granger&#8217;s son was hired.</p>
<p>I believe it was early in this century, 2001 or 2002, that a Star-Telegram Sunday edition front page banner headline shouted something like &#8220;<i>Trinity Uptown to Turn Fort Worth Into Vancouver of the South</i>.&#8221;</p>
<p>Well, turns out my memory is far more accurate than I give it credit for, with my memory validated by a quote from J.D. Granger.</p>
<p>Googling for info about The Boondoggle, I came upon that which you see below,  from the March 3, 2006 edition of the Victoria Advocate. I assume the Advocate is in the Victoria in Texas, not the one in British Columbia, though I can see where a British Columbia newspaper would be interested in a project slated to turn Fort Worth into the Vancouver of the South.</p>
<p>This article has some jaw dropping, ironic, embarrassing quotes from J.D. and the man who hired him, the TRWD henchman known as Jim Oliver.</p>
<div class="separator"><a href="http://1.bp.blogspot.com/-ye9ygf1UWDg/VSxoxZhHfjI/AAAAAAAAbmk/tT8nesXnqj0/s1600/JD%2BGranger.jpg"><img src="http://1.bp.blogspot.com/-ye9ygf1UWDg/VSxoxZhHfjI/AAAAAAAAbmk/tT8nesXnqj0/s1600/JD%2BGranger.jpg" width="500" height="244" border="0" /></a></div>
<p>Nine years ago, when this article was written, the cost of The Boondoggle was still under a half billion dollars, at $435 million.</p>
<p>First paragraph&#8230;</p>
<p>J.D. Granger, whose mother is U.S. Rep. Kay Granger, R-Fort Worth, will earn $110,000 a year and start work Monday at the Tarrant Regional Water District, said Jim Oliver, general manager of the district, which is spearheading the project.</p>
<p>$110,000 a year. In the almost 10 years J.D. has been boondoggling The Boondoggle he has been paid around a million bucks. So much money while doing so little. I wish my mama was in Congress.</p>
<p>J.D. Granger, 36, an assistant Tarrant County district attorney for eight years, also has worked in various volunteer roles during the planning for the Trinity Uptown project, Oliver said.</p>
<p>So, apparently, J.D.&#8217;s qualification for this job is he had various volunteer roles during the planning of what was then called Trinity Uptown.</p>
</div>
<div class="date-posts">
<div class="post-outer">
<div class="post hentry">
<div id="post-body-9221332036705607297" class="post-body entry-content">
<div class="google-auto-placed ap_container"><strong>And then a paragraph of common sense from Clyde Picht&#8230;</strong></div>
<p><strong>Former City Councilman Clyde Picht, who has long questioned aspects of the project and is running for the water district board, said J.D. Granger&#8217;s appointment is &#8220;asking for criticism&#8221; and that his knowledge of water district issues is &#8220;certainly more limited than most people.&#8221;</strong></p>
<p><strong>Yes, J.D.&#8217;s appointment was asking for criticism, what with that Queen of Nespot issue, and the idea that hiring a low level district attorney, with no project management experience, was a good idea.</strong></p>
<p><strong>Try and figure out what is being said in the following paragraph&#8230;</strong></p>
<p><strong>J.D. Granger&#8217;s salary will come from water district funds, not federal money that Kay Granger is securing, Oliver told the Fort Worth Star-Telegram. Those funds do not come directly to the water district, he said.</strong></p>
<div class="google-auto-placed ap_container"></div>
<p><strong>What is Oliver&#8217;s point? Federal money from Kay does not go directly to the district? And so the money paid to Kay&#8217;s son does not come from wherever Kay&#8217;s money goes, but instead comes from district funds? And how does Oliver differentiate where J.D.&#8217;s take is coming from, what with funds coming in from various sources? All ending up in the TRWD pot. What point is made by saying his salary comes from water district funds? What sort of shell game is Oliver trying to play here?</strong></p>
<p><strong>And then there is this additional bit from Oliver&#8230;.</strong></p>
<p><strong>Oliver said he realized that hiring the congresswoman&#8217;s son &#8220;would probably raise some eyebrows&#8221; but felt J.D. Granger was right for the job because of his familiarity and expertise on many facets of the project. Oliver said he thought about several possible candidates but did not conduct a job search.</strong></p>
<p><strong>Nine years later, with the Trinity River Vision now America&#8217;s Biggest Boondoggle, is Jim Oliver still thinking J.D. Granger was the right man for the job? Why was the hiring of J.D. Granger left solely to Jim Oliver? And not the elected TRWD board members? How was this allowed? How did the un-elected Jim Oliver get this dictatorial hiring power? Did this power come from the same unseen entity who gave Oliver key power over newly elected TRWD board members?</strong></p>
<div class="google-auto-placed ap_container"></div>
<p><strong>And then this revealing quote from J.D. Granger which let me know my memory has been right all along as to when The Boondoggle began&#8230;.</strong></p>
<p><strong>J.D. Granger said he&#8217;s been working on the project &#8220;since it was just a vision, back in 1999. I bet I know about as much as any single person out there who&#8217;s not been paid to participate in this,&#8221; he said. &#8220;I know it inside and out, so there&#8217;s not going to be any lag time.&#8221;</strong></p>
<p><strong>No lag time? Nine years after getting hired, with little accomplished. No lag time? What about the incredible lag time of taking eight years to start construction of three little bridges over dry land with an equally incredible lag time of taking four years to build the little bridges, with the scheduled completion of the bridges 13 years after the hiring of J.D. Granger ? If that is not lag time, what does J.D. Granger consider to be lag time?</strong></p>
<p><strong>Next paragraph&#8230;</strong></p>
<p><strong>He (J.D.) said the U.S. Army Corps of Engineers is expected to give final project approval in two weeks. He said he expects one of his first roles to be working with landowners whose property is needed for construction.</strong></p>
<p><strong>How cavalier of Granger. Working with landowners? Soon the working with landowners became abusing eminent domain to take property needed way in the future for those three little bridges and the ditch that one day may be dug beneath them.</strong></p>
<p><strong>And then the final three paragraphs from the Victoria Advocate article&#8230;</strong></p>
<p><strong>J.D. Granger said he considered running for the water district board when he was approached about working for the district.</strong></p>
<div class="google-auto-placed ap_container"></div>
<p><strong>He said his mother&#8217;s involvement at the federal level strengthens his knowledge of the plan. And he said he will try to ensure that the federal price tag &#8220;doesn&#8217;t get any higher.&#8221;</strong><br />
<strong>County Commissioner Roy Brooks said he believes that J.D. Granger will do a good job but said &#8220;some people might not agree with me that there&#8217;s no conflict of interest.&#8221;</strong></p>
<p><strong>Well, count me among those who do not agree that there is no conflict of interest. I also agree with those who would say J.D. has not done a good job ensuring the federal price tag doesn&#8217;t get any higher. It&#8217;s only doubled since J.D. began his life&#8217;s work.</strong></p>
<p><strong>I can not help but want to hear J.D. explain how his mom&#8217;s involvement at the federal level makes his knowledge of the plan stronger.</strong></p>
<p><strong>So, there you go, Fort Worth has a public works project the public has never voted on, a project which began 16 years ago, in 1999. Fort Worth kids, now in high school, have never known a Fort Worth without a bizarre public works project being built in slow motion.</strong></p>
<p><strong>Fort Worth kids now in high school will soon be graduating in the town with the bragging rights to having America&#8217;s Biggest Boondoggle.</strong></p>
<p><strong>Tell me again why anyone in their right mind would vote for a Tarrant Regional Water District incumbent board member?</strong></p>
<div></div>
</div>
<div class="post-footer">
<div class="post-footer-line post-footer-line-1"><strong><strong><span class="post-author vcard">Posted by <span class="fn"><a class="g-profile" title="author profile" href="https://www.blogger.com/profile/10231271044296466883" rel="author" data-gapiscan="true" data-onload="true" data-gapiattached="true">Durango </a></span></span><span class="post-timestamp">at <a class="timestamp-link" title="permanent link" href="http://durangotexas.blogspot.com/2015/04/the-incredible-alternative-universe-of.html" rel="bookmark"><abbr class="published" title="2015-04-16T13:28:00-05:00">1:28 PM</abbr></a> </span><span class="post-icons"><span class="item-action"><a title="Email Post" href="https://www.blogger.com/email-post.g?blogID=6439803544142853007&amp;postID=9221332036705607297"><img class="icon-action" src="http://img1.blogblog.com/img/icon18_email.gif" alt="" width="18" height="13" /></a></p>
<p></span></span></strong></strong></p>
<h2 class="date-header">Wednesday, December 5, 2018</h2>
<div class="date-posts">
<div class="post-outer">
<div class="post hentry"><a name="3434820571890722378"></a></p>
<h3 class="post-title entry-title">Mama Kay Smacks J.D. Granger Again For Saying Dumb Stuff</h3>
<div class="post-header">
<div class="post-header-line-1"></div>
</div>
<div id="post-body-3434820571890722378" class="post-body entry-content">
<div class="separator"><a href="https://1.bp.blogspot.com/-vvrsZmmq_xc/XAhXBBkmqsI/AAAAAAAAkas/kaz3q1R56OoAjoFwQnRPRmBG7nXrsYKmACLcBGAs/s1600/Jd%2BMom.jpg"><img src="https://1.bp.blogspot.com/-vvrsZmmq_xc/XAhXBBkmqsI/AAAAAAAAkas/kaz3q1R56OoAjoFwQnRPRmBG7nXrsYKmACLcBGAs/s400/Jd%2BMom.jpg" width="400" height="248" border="0" data-original-height="280" data-original-width="449" /></a></div>
<p>The last 24, (or is it 48 hours?), I have found myself getting way too much incoming info overwhelming my slow info processing ability.</p>
<p>The info has been about America&#8217;s Biggest Boondoggle, also known as the Trinity River Central City Uptown Panther Island District Vision.</p>
<p>The info has come from various sources.</p>
<p>Such as Deep Moat, also known as our Inside the Boondoggle Information Source. In addition to Deep Moat there have been a couple local NBC TV News stories about Fort Worth&#8217;s ongoing embarrassment. A screen cap from part of  one of those NBC TV News stories you see above.</p>
<p>I think the NBC TV News <b><a href="https://www.nbcdfw.com/news/local/Panther-Island-Project-Leader-Walks-Back-Statements-On-Future-Funding-501940541.html" target="_blank" rel="noopener noreferrer">Panther Island Project Leader Walks Back Statements on Future Funding</a></b> story, from which this screen cap came aired, last night.</p>
<p>I first learned of this latest NBC TV News story via Facebook, this morning. My dear Facebook friend whom I call Mr. Spiffy made an amusing comment about this on Facebook, which sort of sums it up&#8230;</p>
<p><b>John Spivey:</b> I think of Kay Granger and her son JD like Buford T Justice and Junior from “Smokey &amp; the Bandit”. I picture her always smacking him with her cowboy hat and saying “There’s no way YOU came from my loins, boy!” Spoiler alert: JD said a buncha dumb stuff. Again.</p>
<p>The buncha dumb stuff J.D. said this time was said on a NBC TV News report which led to the followup report where J.D. tried to walk back the dumb stuff he said in</p></div>
</div>
</div>
</div>
<p><strong><strong><span class="post-icons"><span class="item-action"><br />
</span></span></strong></strong></p>
<div id="post-body-3434820571890722378" class="post-body entry-content"><b><a href="https://www.nbcdfw.com/investigations/Congresswomans-Son-Vows-to-Finish-Panther-Island-Then-Im-Out-of-Here-501827921.html" target="_blank" rel="noopener noreferrer">Congresswoman&#8217;s Son Vows to Finish &#8216;Panther Island&#8217; Then, &#8216;I&#8217;m Out of Here&#8217;</a></b></p>
<p>I am starting to be a bit burned out by all this. Somehow Kay Granger got herself re-elected. This makes me think Fort Worth deserves what it doesn&#8217;t get. And gets.</p>
<p>Then again, how does anyone know how deep and how nefarious the election fraud is in Tarrant County? Aren&#8217;t we still waiting for the results of that supposed largest Texas election fraud investigation in Texas history? Or, has that been covered up like so much gets covered up that is too troubling to look at in the eminent domain abuse capital of America?</p>
<p>We will likely have more to say on this subject, what with a bit of a backlog of material which begs to be talked about&#8230;</p>
<div></div>
</div>
<div class="post-footer">
<div class="post-footer-line post-footer-line-1"><span class="post-author vcard">Posted by <span class="fn"><a class="g-profile" title="author profile" href="https://www.blogger.com/profile/10231271044296466883" rel="author" data-gapiscan="true" data-onload="true" data-gapiattached="true">Durango </a></span></span><span class="post-timestamp">at <a class="timestamp-link" title="permanent link" href="https://durangotexas.blogspot.com/2018/12/mama-kay-smacks-jd-granger-again-for.html" rel="bookmark"><abbr class="published" title="2018-12-05T17:21:00-06:00">5:21 PM</abbr></a> </span></div>
</div>
<p><strong><span class="post-icons"><span class="item-action"><br />
</span></span></strong></div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<p>&nbsp;</p>
<h1><strong><a href="https://email.empowertexans.com/t/d-l-xujhjhy-urdyahlt-j/">Granger’s Panther Island Still in Design Phase After 13 Years</a></strong></h1>
<p><strong>by Robert Montoya and Ross Kecseg</strong></p>
<p><strong>On Wednesday, a billion-dollar redevelopment scheme overseen by the son of a congresswoman revealed that its design phase is not yet complete. This runs counter to findings published last year by a third-party review, which claimed that the design phase was finished after 13 years and more than $383 million spent.</strong></p>
<p><strong>Panther Island is a massive taxpayer-funded government project conceived in 2003 to reroute the Trinity River via a 1.5-mile bypass—and redevelop prime Fort Worth real estate north of downtown—under the guise of flood control.</strong></p>
<p><strong>The joint venture involves the U.S. Army Corps of Engineers (USACE), Texas Department of Transportation (TxDOT), Tarrant County, the Tarrant Regional Water District (TRWD), the City of Fort Worth, and the Trinity River Vision Authority (TRVA). The TRVA was tasked with coordinating the project, the cost of which has ballooned from $435 million in 2006 to more than $1.17 billion in 2018.</strong></p>
<p><strong>To lead this project, TRWD General Manager supported picking J.D. Granger—son of U.S. Rep. Kay Granger—to run the TRVA <a href="https://email.empowertexans.com/t/d-l-xujhjhy-urdyahlt-t/">despite lacking any related education or work experience.</a> He was hired in 2006.</strong></p>
<p><strong>After 13 years of cost overruns, delays, construction problems, and mismanagement, the Trump administration froze federal funding, prompting a third-party<a href="https://email.empowertexans.com/t/d-l-xujhjhy-urdyahlt-i/"> programmatic review</a> of the troubled project. Despite $383 million being spent, the review found no aspect of construction completed—only the design phase.</strong></p>
<p><strong>Now officials not only admit this claim is inaccurate, but they say the progress of the ongoing design is unknown.</strong></p>
<p><strong>Wednesday <a href="https://email.empowertexans.com/t/d-l-xujhjhy-urdyahlt-d/">Mark Mazzanti—formerly of USACE and hired in December as TRVA’s new “program coordinator”— </a>told the TRVA board that President Trump had signed into law federal appropriations for roughly $170 million for flood control projects across the nation; he expects to hear in February if USACE and the administration will assign any of this to Panther Island.</strong></p>
<p><strong>“But for us to stay [on schedule], we need $38 million of $170 million, which is 22 percent of all the funds in the country,” asked TRVA and TRWD Board Member James Hill.</strong></p>
<p><strong>Mazzanti said $38 million is what they have asked for and what is needed for USACE to complete their “design for all construction options.” To stay on schedule, they need only $10 million.</strong></p>
<p><strong>“The Corps has not indicated [assigning] anything less than $38 million,” Mazzanti said;</strong></p>
<p><strong>After hearing Mazzanti’s statement, Fort Worth City Manager David Cooke asked about the status of the design phase. “So, I’ve been told [USACE] has done 60 percent design. Is that a true statement?”</strong></p>
<p><strong>“No,” Mazzanti replied.</strong></p>
<p><strong>“What would a true statement be?” Cooke asked. Mazzanti couldn’t say what their current progress is, but said he “could check on that.”</strong></p>
<p><strong>“There are a number of designs that are ongoing,” Mazzanti said at one point.</strong></p>
<p><strong>This stunning admission conflicts with the findings of the third-party programmatic review, but confirms a statement from TRWD lawyer’s to <a href="https://email.empowertexans.com/t/d-l-xujhjhy-urdyahlt-h/">Texas’ attorney general</a> last year that the project’s design phase still is incomplete after 13 years and more than $383 million spent.</strong></p>
<p><strong>If federal funding is restored, taxpayers will again be exposed to the ongoing financial risk of this increasingly expensive boondoggle, without a financial or forensic audit ever having been conducted to disclose where hundreds of millions in tax dollars have already been spent.</strong></p>
<p>&nbsp;</p>
<h1></h1>
      

    
       <div class="mom-social-share ss-horizontal border-box php-share" data-id="28083">
                    <div class="ss-icon facebook">
                <a href="#" onclick="window.open('http://www.facebook.com/sharer/sharer.php?u=https://www.localnewsonly.com/2020/01/kay-granger-and-j-d-granger-tarrant-counties-joe-and-hunter-biden/', 'Share This', 'menubar=no,toolbar=no,resizable=no,scrollbars=no, width=600,height=455');"><span class="icon"><i class="fa-icon-facebook"></i>Share</span></a>
                <span class="count">0</span>
            </div> <!--icon-->
        
                    <div class="ss-icon twitter">
                <a href="http://twitter.com/share?text=Kay Granger and J.D. Granger &#8211; Tarrant Counties &#8211; &#8220;Joe and Hunter Biden&#8221;&url=https://www.localnewsonly.com/2020/01/kay-granger-and-j-d-granger-tarrant-counties-joe-and-hunter-biden/" onclick="window.open(this.href, 'Post this on twitter', 'menubar=no,toolbar=no,resizable=no,scrollbars=no,width=600,height=455');"><span class="icon"><i class="fa-icon-twitter"></i>Tweet</span></a>
            </div> <!--icon-->
        
                    <div class="ss-icon googleplus">
                <a href="#"
onclick="window.open('https://plus.google.com/share?url=https://www.localnewsonly.com/2020/01/kay-granger-and-j-d-granger-tarrant-counties-joe-and-hunter-biden/', '', 'menubar=no,toolbar=no,resizable=no,scrollbars=no,height=455,width=600');return false"><span class="icon"><i class="fa-icon-google-plus"></i>Share</span></a>
            </div> <!--icon-->
                                    <div class="ss-icon linkedin">
                <a href="#"
onclick="javascript:window.open('http://www.linkedin.com/shareArticle?mini=true&url=https://www.localnewsonly.com/2020/01/kay-granger-and-j-d-granger-tarrant-counties-joe-and-hunter-biden/&title=Kay Granger and J.D. Granger &#8211; Tarrant Counties &#8211; &#8220;Joe and Hunter Biden&#8221;&source=https%3A%2F%2Fwww.localnewsonly.com', '', 'menubar=no,toolbar=no,resizable=no,scrollbars=no,height=455,width=600');return false;"><span class="icon"><i class="fa-icon-linkedin"></i>Share</span></a>
                <span class="count"></span>
            </div> <!--icon-->
                            <div class="ss-icon pinterest">
                <a href="http://pinterest.com/pin/create/bookmarklet/?media=http://1.bp.blogspot.com/-dmGu5P61cZE/VSxoxOpcDBI/AAAAAAAAbmg/wPUh1uCcogs/s1600/Grangers.jpg&amp;
url=https://www.localnewsonly.com/2020/01/kay-granger-and-j-d-granger-tarrant-counties-joe-and-hunter-biden/&amp;
is_video=false&amp;description=Kay Granger and J.D. Granger &#8211; Tarrant Counties &#8211; &#8220;Joe and Hunter Biden&#8221;"
onclick="javascript:window.open(this.href, '_blank', 'menubar=no,toolbar=no,resizable=no,scrollbars=no,height=455,width=600');return false;"><span class="icon"><i class="fa-icon-pinterest"></i>Share</span></a>
                <span class="count"></span>
            </div> <!--icon-->
                            <div class="clear"></div>
        </div> <!--social share-->

</div> <!-- entry content -->
</div> <!-- base box -->

            <div class="np-posts">
                <ul>
			                    <li class="np-post prev border-box">
						<div class="post-img">
                            <a href="https://www.localnewsonly.com/2020/01/mclaren-dallas-gives-11-year-old-childrens-health-sm-patient-the-ride-of-his-life-in-a-mclaren-720s/"><img src="https://www.localnewsonly.com/wp-content/uploads/2020/01/McL014x-90x60.jpg" data-hidpi="https://www.localnewsonly.com/wp-content/uploads/2020/01/McL014x-180x120.jpg" alt="Kay Granger and J.D. Granger - Tarrant Counties - "Joe and Hunter Biden""></a>
                        </div>
			                        <div class="details has-feature-image">
                            <a href="https://www.localnewsonly.com/2020/01/mclaren-dallas-gives-11-year-old-childrens-health-sm-patient-the-ride-of-his-life-in-a-mclaren-720s/" class="link prev"><i class="fa-icon-double-angle-left"></i>Previous</a>
                            <h3><a href="https://www.localnewsonly.com/2020/01/mclaren-dallas-gives-11-year-old-childrens-health-sm-patient-the-ride-of-his-life-in-a-mclaren-720s/">McLaren Dallas Gives 11-Year-Old Children’s Health SM Patient the Ride of His Life in a McLaren 720S</a></h3>
                        </div>
                    </li>
		    		                    </ul>
            </div> <!-- np posts -->
<h2 class="single-title">About the author</h2>
            <div class="base-box single-box about-the-author">
                <div class="author_avatar"><img alt='' src='https://secure.gravatar.com/avatar/78a913b0132ffb6c82ba7d42b0e8c7e4?s=80&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/78a913b0132ffb6c82ba7d42b0e8c7e4?s=160&#038;d=mm&#038;r=g 2x' class='avatar avatar-80 photo' height='80' width='80' /></div>
                <div class="author_desc">
                    <h3 calss="vcard author"><span class="fn"><a href="https://www.localnewsonly.com/author/nelson/">Editor - Nelson Thibodeaux</a></span>  </span></h3>
        <p>
		editor@localnewsonly.com
Nelson is a 30-year plus resident of Colleyville. He has located his privately owned businesses in Colleyville for more than 20 years.

Nelson is the 2018 Empower Texans Recipient of the North Texas Conservative Leadership Award.

Nelson is the founder of LNO in 2000.  He served as councilman and Mayor Pro Tem of Colleyville until June 2000.  Thereafter he started LNO because there was no adequate newspaper coverage.  

Nelson has previously worked in both radio and television during his career.	</p>
                 <div class="mom-socials-icons author-social-icons">
        <ul>
                    <li class="home"><a target="_blank" href="https://www.localnewsonly.com"><i class=" momizat-icon-home "></i></a></li>                    <li class="facebook"><a target="_blank" href="http://www.facebook.com/localnewsonly"><i class="fa-icon-facebook "></i></a></li>                                                           <li class="rss"><a target="_blank" href="https://www.localnewsonly.com/author/nelson/feed/"><i class="fa-icon-rss"></i></a></li>
                                                                                                                                                                        </u>

        <div class="clear"></div>
    </div>

                </div>
	            <div class="clear"></div>

            </div>
                <h2 class="single-title">Related Articles</h2>
            <div class="base-box single-box">
                <ul class="single-related-posts">
	   	     	       <li>
			                        <h4><a itemprop="name" href="https://www.localnewsonly.com/2020/01/u-s-census-bureau-launches-first-2020-census-ads/">U.S. Census Bureau Launches First 2020 Census Ads</a></h4>
                        <div class="mom-post-meta">
			<time datetime="2020-01-11T11:02:26-06:00">January 11, 2020</time>
			</div>
                </li>

	       <li>
			                        <a href="https://www.localnewsonly.com/2019/12/recent-arrests-in-southlake-texas-special-educator-at-keller-isd-charged-with-injury-to-a-child-or-elderly-disable-intent-on-bodily-injury/"><img src="https://www.localnewsonly.com/wp-content/uploads/2019/12/OrtegaK-190x122.jpg" data-hidpi="https://www.localnewsonly.com/wp-content/uploads/2019/12/OrtegaK-450x380.jpg" alt="Recent Arrests in Southlake, Texas - Special Educator at Keller ISD Charged with Injury to a Child or Elderly/Disable intent on Bodily Injury!"></a>
			                        <h4><a itemprop="name" href="https://www.localnewsonly.com/2019/12/recent-arrests-in-southlake-texas-special-educator-at-keller-isd-charged-with-injury-to-a-child-or-elderly-disable-intent-on-bodily-injury/">Recent Arrests in Southlake, Texas &#8211; Special Educator at Keller ISD Charged with Injury to a Child or Elderly/Disable intent on Bodily Injury!</a></h4>
                        <div class="mom-post-meta">
			<time datetime="2019-12-27T15:35:48-06:00">December 27, 2019</time>
			</div>
                </li>

	       <li>
			                        <h4><a itemprop="name" href="https://www.localnewsonly.com/2019/12/see-snap-shot-of-all-salaries-paid-by-the-city-of-colleyville/">See Snap-Shot of all salaries paid by the City of Colleyville</a></h4>
                        <div class="mom-post-meta">
			<time datetime="2019-12-18T17:18:23-06:00">December 18, 2019</time>
			</div>
                </li>

</ul>
</div>

<div id="comments" class="comments-area">

	
		
		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2020/01/kay-granger-and-j-d-granger-tarrant-counties-joe-and-hunter-biden/#respond" style="display:none;">Cancel Reply</a></small></h3>			<form action="https://www.localnewsonly.com/wp-comments-post.php" method="post" id="commentform" class="comment-form">
				<p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><textarea id="comment" placeholder="Comment..." name="comment" cols="45" rows="8" aria-required="true"></textarea></p><input id="author" name="author" type="text" placeholder="Name (required)" value="" size="30" aria-required='true' />
<input id="email" name="email" type="text" placeholder="Email (required)" value="" size="30" aria-required='true' />
<input id="url" name="url" type="text" placeholder="Website" value="" size="30" />
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /><label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="form-submit"><input name="submit" type="submit" id="submit-comment" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='28083' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><input type='hidden' id='ct_checkjs_9b698eb3105bd82528f23d0c92dedfc0' name='ct_checkjs' value='0' /><script type='text/javascript'>setTimeout(function(){apbct_sendAJAXRequest({action: 'apbct_js_keys__get'},{callback: apbct_js_keys__set_input_value, input_name: 'ct_checkjs_9b698eb3105bd82528f23d0c92dedfc0'});}, 1000);</script>			</form>
			</div><!-- #respond -->
	
</div><!-- #comments .comments-area -->
            </div> <!--main column-->
                      <div class="sidebar secondary-sidebar" role="complementary" itemscope="itemscope" itemtype="http://schema.org/WPSideBar">
            
            </div> <!--main sidebar-->
            <div class="clear"></div>
            <div class="clear"></div>
</div> <!--main container-->            
            <div class="sidebar main-sidebar" role="complementary" itemscope="itemscope" itemtype="http://schema.org/WPSideBar">
            <div class="widget momizat-posts"><div class="widget-head"><h3 class="widget-title"><span>Recent Posts</span></h3></div>                                   <div class="mom-posts-widget">

					<div class="mpw-post">
							    <div class="post-img main-sidebar-element"><a href="https://www.localnewsonly.com/2020/01/kay-granger-and-j-d-granger-tarrant-counties-joe-and-hunter-biden/"><img src="http://1.bp.blogspot.com/-dmGu5P61cZE/VSxoxOpcDBI/AAAAAAAAbmg/wPUh1uCcogs/s1600/Grangers.jpg" data-hidpi="http://1.bp.blogspot.com/-dmGu5P61cZE/VSxoxOpcDBI/AAAAAAAAbmg/wPUh1uCcogs/s1600/Grangers.jpg" alt="Kay Granger and J.D. Granger - Tarrant Counties - "Joe and Hunter Biden"" width="90" height="60"></a></div>
			    <div class="post-img sec-sidebar-element"><a href="https://www.localnewsonly.com/2020/01/kay-granger-and-j-d-granger-tarrant-counties-joe-and-hunter-biden/"><img src="http://1.bp.blogspot.com/-dmGu5P61cZE/VSxoxOpcDBI/AAAAAAAAbmg/wPUh1uCcogs/s1600/Grangers.jpg" data-hidpi="http://1.bp.blogspot.com/-dmGu5P61cZE/VSxoxOpcDBI/AAAAAAAAbmg/wPUh1uCcogs/s1600/Grangers.jpg" alt="Kay Granger and J.D. Granger - Tarrant Counties - "Joe and Hunter Biden"" width="180" height="120"></a><span class="post-format-icon"></span></div>
			    			   <div class="details has-feature-image">
			    <h4><a href="https://www.localnewsonly.com/2020/01/kay-granger-and-j-d-granger-tarrant-counties-joe-and-hunter-biden/">Kay Granger and J.D. Granger &#8211; Tarrant Counties &#8211; &#8220;Joe and Hunter Biden&#8221;</a></h4>
			   <div class="mom-post-meta mom-w-meta">
				<span datetime="2020-01-14T18:02:56-06:00" class="entry-date">January 14, 2020</span>
			    			    </div>
			</div>
			</div> <!--//post-->

						<div class="mpw-post">
							    <div class="post-img main-sidebar-element"><a href="https://www.localnewsonly.com/2020/01/mclaren-dallas-gives-11-year-old-childrens-health-sm-patient-the-ride-of-his-life-in-a-mclaren-720s/"><img src="https://www.localnewsonly.com/wp-content/uploads/2020/01/McL014x-90x60.jpg" data-hidpi="https://www.localnewsonly.com/wp-content/uploads/2020/01/McL014x-90x60.jpg" alt="McLaren Dallas Gives 11-Year-Old Children’s Health SM Patient the Ride of His Life in a McLaren 720S" width="90" height="60"></a></div>
			    <div class="post-img sec-sidebar-element"><a href="https://www.localnewsonly.com/2020/01/mclaren-dallas-gives-11-year-old-childrens-health-sm-patient-the-ride-of-his-life-in-a-mclaren-720s/"><img src="https://www.localnewsonly.com/wp-content/uploads/2020/01/McL014x-180x120.jpg" data-hidpi="https://www.localnewsonly.com/wp-content/uploads/2020/01/McL014x-180x120.jpg" alt="McLaren Dallas Gives 11-Year-Old Children’s Health SM Patient the Ride of His Life in a McLaren 720S" width="180" height="120"></a><span class="post-format-icon"></span></div>
			    			   <div class="details has-feature-image">
			    <h4><a href="https://www.localnewsonly.com/2020/01/mclaren-dallas-gives-11-year-old-childrens-health-sm-patient-the-ride-of-his-life-in-a-mclaren-720s/">McLaren Dallas Gives 11-Year-Old Children’s Health SM Patient the Ride of His Life in a McLaren 720S</a></h4>
			   <div class="mom-post-meta mom-w-meta">
				<span datetime="2020-01-13T14:15:52-06:00" class="entry-date">January 13, 2020</span>
			    			    </div>
			</div>
			</div> <!--//post-->

						<div class="mpw-post">
							    <div class="post-img main-sidebar-element"><a href="https://www.localnewsonly.com/2020/01/recent-arrests-and-book-ins-at-grapevine-city-jail-2/"><img src="https://www.localnewsonly.com/wp-content/uploads/2015/07/GrapevinePoliceBookingOpen-90x60.jpg" data-hidpi="https://www.localnewsonly.com/wp-content/uploads/2015/07/GrapevinePoliceBookingOpen-90x60.jpg" alt="Recent arrests and book-ins at Grapevine City Jail" width="90" height="60"></a></div>
			    <div class="post-img sec-sidebar-element"><a href="https://www.localnewsonly.com/2020/01/recent-arrests-and-book-ins-at-grapevine-city-jail-2/"><img src="https://www.localnewsonly.com/wp-content/uploads/2015/07/GrapevinePoliceBookingOpen-180x120.jpg" data-hidpi="https://www.localnewsonly.com/wp-content/uploads/2015/07/GrapevinePoliceBookingOpen-180x120.jpg" alt="Recent arrests and book-ins at Grapevine City Jail" width="180" height="120"></a><span class="post-format-icon"></span></div>
			    			   <div class="details has-feature-image">
			    <h4><a href="https://www.localnewsonly.com/2020/01/recent-arrests-and-book-ins-at-grapevine-city-jail-2/">Recent arrests and book-ins at Grapevine City Jail</a></h4>
			   <div class="mom-post-meta mom-w-meta">
				<span datetime="2020-01-13T13:58:19-06:00" class="entry-date">January 13, 2020</span>
			    			    </div>
			</div>
			</div> <!--//post-->

						<div class="mpw-post">
							    <div class="post-img main-sidebar-element"><a href="https://www.localnewsonly.com/2020/01/recent-arrests-in-southlake-4/"><img src="https://www.localnewsonly.com/wp-content/uploads/2020/01/Fusco-A-90x60.jpg" data-hidpi="https://www.localnewsonly.com/wp-content/uploads/2020/01/Fusco-A-90x60.jpg" alt="Recent Arrests in Southlake" width="90" height="60"></a></div>
			    <div class="post-img sec-sidebar-element"><a href="https://www.localnewsonly.com/2020/01/recent-arrests-in-southlake-4/"><img src="https://www.localnewsonly.com/wp-content/uploads/2020/01/Fusco-A-180x120.jpg" data-hidpi="https://www.localnewsonly.com/wp-content/uploads/2020/01/Fusco-A-180x120.jpg" alt="Recent Arrests in Southlake" width="180" height="120"></a><span class="post-format-icon"></span></div>
			    			   <div class="details has-feature-image">
			    <h4><a href="https://www.localnewsonly.com/2020/01/recent-arrests-in-southlake-4/">Recent Arrests in Southlake</a></h4>
			   <div class="mom-post-meta mom-w-meta">
				<span datetime="2020-01-13T13:44:45-06:00" class="entry-date">January 13, 2020</span>
			    			    </div>
			</div>
			</div> <!--//post-->

						<div class="mpw-post">
							   <div class="details ">
			    <h4><a href="https://www.localnewsonly.com/2020/01/tragedy-in-southlake-takes-students-life/">Tragedy in Southlake takes student&#8217;s life</a></h4>
			   <div class="mom-post-meta mom-w-meta">
				<span datetime="2020-01-13T12:17:02-06:00" class="entry-date">January 13, 2020</span>
			    			    </div>
			</div>
			</div> <!--//post-->

						<div class="mpw-post">
							   <div class="details ">
			    <h4><a href="https://www.localnewsonly.com/2020/01/texas-minute-michael-sullivan/">Texas  Minute &#8211; Michael Sullivan</a></h4>
			   <div class="mom-post-meta mom-w-meta">
				<span datetime="2020-01-11T13:01:54-06:00" class="entry-date">January 11, 2020</span>
			    			    </div>
			</div>
			</div> <!--//post-->

						<div class="mpw-post">
							    <div class="post-img main-sidebar-element"><a href="https://www.localnewsonly.com/2020/01/weekly-report-from-grapevine-city-jail/"><img src="https://www.localnewsonly.com/wp-content/uploads/2015/07/GrapevinePoliceBookingOpen-90x60.jpg" data-hidpi="https://www.localnewsonly.com/wp-content/uploads/2015/07/GrapevinePoliceBookingOpen-90x60.jpg" alt="Weekly Report from Grapevine City Jail" width="90" height="60"></a></div>
			    <div class="post-img sec-sidebar-element"><a href="https://www.localnewsonly.com/2020/01/weekly-report-from-grapevine-city-jail/"><img src="https://www.localnewsonly.com/wp-content/uploads/2015/07/GrapevinePoliceBookingOpen-180x120.jpg" data-hidpi="https://www.localnewsonly.com/wp-content/uploads/2015/07/GrapevinePoliceBookingOpen-180x120.jpg" alt="Weekly Report from Grapevine City Jail" width="180" height="120"></a><span class="post-format-icon"></span></div>
			    			   <div class="details has-feature-image">
			    <h4><a href="https://www.localnewsonly.com/2020/01/weekly-report-from-grapevine-city-jail/">Weekly Report from Grapevine City Jail</a></h4>
			   <div class="mom-post-meta mom-w-meta">
				<span datetime="2020-01-11T12:52:04-06:00" class="entry-date">January 11, 2020</span>
			    			    </div>
			</div>
			</div> <!--//post-->

						<div class="mpw-post">
							    <div class="post-img main-sidebar-element"><a href="https://www.localnewsonly.com/2020/01/grapevine-police-arrest-21-year-old-for-murder/"><img src="https://www.localnewsonly.com/wp-content/uploads/2020/01/Bigham-Antonio-2-90x60.jpg" data-hidpi="https://www.localnewsonly.com/wp-content/uploads/2020/01/Bigham-Antonio-2-90x60.jpg" alt="Grapevine Police Arrest 21 year old for Murder!" width="90" height="60"></a></div>
			    <div class="post-img sec-sidebar-element"><a href="https://www.localnewsonly.com/2020/01/grapevine-police-arrest-21-year-old-for-murder/"><img src="https://www.localnewsonly.com/wp-content/uploads/2020/01/Bigham-Antonio-2-180x120.jpg" data-hidpi="https://www.localnewsonly.com/wp-content/uploads/2020/01/Bigham-Antonio-2-180x120.jpg" alt="Grapevine Police Arrest 21 year old for Murder!" width="180" height="120"></a><span class="post-format-icon"></span></div>
			    			   <div class="details has-feature-image">
			    <h4><a href="https://www.localnewsonly.com/2020/01/grapevine-police-arrest-21-year-old-for-murder/">Grapevine Police Arrest 21 year old for Murder!</a></h4>
			   <div class="mom-post-meta mom-w-meta">
				<span datetime="2020-01-11T12:39:51-06:00" class="entry-date">January 11, 2020</span>
			    			    </div>
			</div>
			</div> <!--//post-->

						<div class="mpw-post">
							    <div class="post-img main-sidebar-element"><a href="https://www.localnewsonly.com/2020/01/sexual-assault-of-a-child-included-in-recent-arrests-in-colleyville/"><img src="https://www.localnewsonly.com/wp-content/uploads/2020/01/Christopher-Ray-Johnson-90x60.jpg" data-hidpi="https://www.localnewsonly.com/wp-content/uploads/2020/01/Christopher-Ray-Johnson-90x60.jpg" alt="Sexual Assault of a Child --- Included in Recent Arrests in Colleyville" width="90" height="60"></a></div>
			    <div class="post-img sec-sidebar-element"><a href="https://www.localnewsonly.com/2020/01/sexual-assault-of-a-child-included-in-recent-arrests-in-colleyville/"><img src="https://www.localnewsonly.com/wp-content/uploads/2020/01/Christopher-Ray-Johnson-180x120.jpg" data-hidpi="https://www.localnewsonly.com/wp-content/uploads/2020/01/Christopher-Ray-Johnson-180x120.jpg" alt="Sexual Assault of a Child --- Included in Recent Arrests in Colleyville" width="180" height="120"></a><span class="post-format-icon"></span></div>
			    			   <div class="details has-feature-image">
			    <h4><a href="https://www.localnewsonly.com/2020/01/sexual-assault-of-a-child-included-in-recent-arrests-in-colleyville/">Sexual Assault of a Child &#8212; Included in Recent Arrests in Colleyville</a></h4>
			   <div class="mom-post-meta mom-w-meta">
				<span datetime="2020-01-11T12:21:12-06:00" class="entry-date">January 11, 2020</span>
			    			    </div>
			</div>
			</div> <!--//post-->

						<div class="mpw-post">
							   <div class="details ">
			    <h4><a href="https://www.localnewsonly.com/2020/01/u-s-census-bureau-launches-first-2020-census-ads/">U.S. Census Bureau Launches First 2020 Census Ads</a></h4>
			   <div class="mom-post-meta mom-w-meta">
				<span datetime="2020-01-11T11:02:26-06:00" class="entry-date">January 11, 2020</span>
			    			    </div>
			</div>
			</div> <!--//post-->

						<div class="mpw-post">
							    <div class="post-img main-sidebar-element"><a href="https://www.localnewsonly.com/2020/01/colleyville-teen-accused-of-7-11-robbery-cornered-at-his-home-by-a-swat-team-ends-his-life-with-self-inflicted-gun-wound/"><img src="https://www.localnewsonly.com/wp-content/uploads/2020/01/Euless-robbery-1-90x60.jpg" data-hidpi="https://www.localnewsonly.com/wp-content/uploads/2020/01/Euless-robbery-1-90x60.jpg" alt="Colleyville Teen Accused of 7-11 Robbery - cornered at his home by a Swat Team...ends his life with self-inflicted gun wound." width="90" height="60"></a></div>
			    <div class="post-img sec-sidebar-element"><a href="https://www.localnewsonly.com/2020/01/colleyville-teen-accused-of-7-11-robbery-cornered-at-his-home-by-a-swat-team-ends-his-life-with-self-inflicted-gun-wound/"><img src="https://www.localnewsonly.com/wp-content/uploads/2020/01/Euless-robbery-1-180x120.jpg" data-hidpi="https://www.localnewsonly.com/wp-content/uploads/2020/01/Euless-robbery-1-180x120.jpg" alt="Colleyville Teen Accused of 7-11 Robbery - cornered at his home by a Swat Team...ends his life with self-inflicted gun wound." width="180" height="120"></a><span class="post-format-icon"></span></div>
			    			   <div class="details has-feature-image">
			    <h4><a href="https://www.localnewsonly.com/2020/01/colleyville-teen-accused-of-7-11-robbery-cornered-at-his-home-by-a-swat-team-ends-his-life-with-self-inflicted-gun-wound/">Colleyville Teen Accused of 7-11 Robbery &#8211; cornered at his home by a Swat Team&#8230;ends his life with self-inflicted gun wound.</a></h4>
			   <div class="mom-post-meta mom-w-meta">
				<span datetime="2020-01-11T10:49:36-06:00" class="entry-date">January 11, 2020</span>
			    			    </div>
			</div>
			</div> <!--//post-->

						<div class="mpw-post">
							   <div class="details ">
			    <h4><a href="https://www.localnewsonly.com/2020/01/texas-history-the-pig-war/">Texas History,  the Pig War</a></h4>
			   <div class="mom-post-meta mom-w-meta">
				<span datetime="2020-01-07T11:09:16-06:00" class="entry-date">January 07, 2020</span>
			    			    </div>
			</div>
			</div> <!--//post-->

						<div class="mpw-post">
							   <div class="details ">
			    <h4><a href="https://www.localnewsonly.com/2020/01/recruiting-underway-nationwide-from-census-bureau-for-more-hires/">Recruiting Underway Nationwide from Census Bureau for more hires</a></h4>
			   <div class="mom-post-meta mom-w-meta">
				<span datetime="2020-01-07T11:03:09-06:00" class="entry-date">January 07, 2020</span>
			    			    </div>
			</div>
			</div> <!--//post-->

									                                    </div>
</div>
           </div> <!--main sidebar-->
            <div class="clear"></div>                      </div> <!--main inner-->
            
      </div> <!--content boxed wrapper-->
                        <footer id="footer">
                <div class="inner">
	     			        	    
        <div class="clear"></div>
                </div> <!--// footer inner-->
            </footer> <!--//footer-->
            <div class="copyrights-area">
                <div class="inner">
                    <p class="copyrights-text">2017, Local News Only</p>
                    				                <div class="responsive-toggle">
                	<a class="desktop-version" href="?responsive=false">Desktop Version</a>
                	<a class="mobile-version" href="?responsive=true">Mobile Version</a>
                </div>
                                </div>
           </div>
            <div class="clear"></div>
        </div> <!--Boxed wrap-->
        	<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-50776477-6', 'auto');
  ga('send', 'pageview');

</script>        <script type='text/javascript' src='https://www.localnewsonly.com/wp-includes/js/comment-reply.min.js?ver=5.2.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/www.localnewsonly.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.localnewsonly.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.1.3'></script>
<script type='text/javascript' src='https://www.localnewsonly.com/wp-content/themes/goodnews5/js/plugins.js?ver=1.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var momAjaxL = {"url":"https:\/\/www.localnewsonly.com\/wp-admin\/admin-ajax.php","nonce":"d5245af861","success":"check your email to complete subscription","error":"Already subscribed","error2":"Email invalid","werror":"Enter a valid city name.","nomore":"No More Posts","homeUrl":"https:\/\/www.localnewsonly.com","viewAll":"View All","noResults":"Sorry, no posts matched your criteria","bodyad":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.localnewsonly.com/wp-content/themes/goodnews5/js/main.js?ver=1.0'></script>
<script type='text/javascript' src='https://www.localnewsonly.com/wp-content/plugins/js_composer/assets/lib/prettyphoto/js/jquery.prettyPhoto.min.js?ver=5.6'></script>
<script type='text/javascript' src='https://www.localnewsonly.com/wp-includes/js/wp-embed.min.js?ver=5.2.2'></script>
    </body>
</html>
